[JAMAIS FINI] Évanescence des cartes Suisses

Problème/bug rencontré sur le site, évolution/amélioration à proposer
Avatar du membre
sly
Messages : 1945
Enregistré le : dim. 29 févr., 2004 6:59 pm
Localisation : Chambéry - Savoie
Contact :

Message par sly » lun. 05 mars, 2012 12:32 pm

Avant tout, un immense bravo à toi pour ton courage à affronter les contraintes de ces tiers, qui, comme tu le soulignes, ne font pas vraiment tout pour rendre le plus accessible et de manière la plus standard possible leurs cartes

Je rajouterais même que je ne connais aucun site qui propose autant de fond de carte que ce que tu as réussi à faire sur chemineur et wri.
Dominique a écrit : - Entre temps, SwissTopo à mis à disposition le protocole "WMTS"
WMTS ? je le connais pas celui-là, ce serait pas pluôt WMS ?
Moralité : nous vivons dans un monde extrêmement mouvant ou tout change tout le temps et ou s'adapter demande une énergie considérable, surtout si on veut garder un peu d'autonomie et utiliser des logiciels et interfaces libres de droits
Oui mais sur ce coup là, le problème vient avant tout de ceux qui fournissent les cartes et qui, à mon avis, font un effort particulier pour ne justement pas être compatible et s'assurer l'utilisation de leur version rien qu'a eux et pouvoir ensuite imposer.
Je ne dis pas que l'évolution d'OL, API IGN, SwissTopo, ... à été voulue dans ce sens, mais que tout ça est gratuit au début pour appâter le gogo qui s'enferre et à de plus en plus de mal à suivre sans payer à un moment.
Interrogeons nous sur la pérennité de tout ça...
Moi je n'hésites pas à le dire : ça a été voulu dans ce sens. Et même si au jour le jour, le développeur ajoute des fonctionnalités qui lui semble pertinentes et utile pour l'avenir, aucun chef de projet n'impose une compatibilité ascendante et l'excuse "manque de moyen" me semble d'une parfaite mauvaise foi et cache en fait une volonté de maintenir sous contrôle les "gogo"

Quant à la pérennité de tout ça, elle m'inquiète fort et tant que la volonté des google/ign/suisstopo ne sera pas de facilité l'utilisation (et je ne vois pas pourquoi ça arriverait), je ne vois pas comment on pourra obtenir la moindre pérennité.

Je dirais donc que tant que tu à le courage pour fixer du scotch là où ça s'écroule, continuons de manière bancale, le jour où tu en aura marre, on aura qu'a dire tchao à suisstopo IGN et google et je ne verserais aucune larme.

Les seules cartes qui resterons seront donc des cartes libres, celles que l'on peut contrôler, celles pour lesquelles on est pas des "gogo" qui suivent le bon vouloir de financiers âpres au gain.
En gros, celles basées sur openstreetmap

Avatar du membre
Dominique
Messages : 1150
Enregistré le : sam. 08 avr., 2006 9:58 pm
Localisation : Chaville 92
Contact :

Message par Dominique » lun. 05 mars, 2012 2:48 pm

sly a écrit :... ton courage à affronter les contraintes de ces tiers ..
C'est juste que ça m'amuse
sly a écrit :... ne font pas vraiment tout pour rendre le plus accessible et de manière la plus standard possible leurs cartes
En fait si, la nouvelle API SwissTopo permet de mettre une carte sur un site en 4 lignes très simples, c'est juste que je ne veux pas faire comme tout le monde et passer par OL
sly a écrit :WMTS ? je le connais pas celui-là, ce serait pas plutôt WMS ?
http://opengeospatial.org/standards/wmts (04/2010) Une vrai galère : il faut d'abord interroger le serveur sur ses "Capabilities", attendre la réponse, et seulement à ce moment là générer la couche.

Avatar du membre
sly
Messages : 1945
Enregistré le : dim. 29 févr., 2004 6:59 pm
Localisation : Chambéry - Savoie
Contact :

Message par sly » lun. 05 mars, 2012 3:10 pm

En fait si, la nouvelle API SwissTopo permet de mettre une carte sur un site en 4 lignes très simples
C'est une fausse impression de simplicité vu que ça nécessite leur API, un "vrai" truc simple dans ma définition, c'est quand on peut avoir ce résultat en 4 lignes sur n'importe quelle libraire de gestion de carte.
Par exemple, les tuiles openstreetmap peuvent être ajoutées en ~4 lignes sur OL, leaflet, et gmaps API. C'est ça que j'appel simple et compatible.
c'est juste que je ne veux pas faire comme tout le monde et passer par OL
Et je te soutiens dans cette démarche, l'indépendance, ça n'a pas de prix, et c'est le seul chemin vers un semblant de pérennité.
Modifié en dernier par sly le mer. 02 mai, 2012 3:01 pm, modifié 1 fois.

Swisstrekker
Messages : 181
Enregistré le : mar. 13 avr., 2010 9:41 pm
Localisation : Alpes vaudoises

Message par Swisstrekker » ven. 09 mars, 2012 8:29 pm

Motivation et efforts impressionnants : bravo !

Avatar du membre
Dominique
Messages : 1150
Enregistré le : sam. 08 avr., 2006 9:58 pm
Localisation : Chaville 92
Contact :

Message par Dominique » dim. 22 avr., 2012 6:45 pm

Bonjour

avec un peu de retard, les pluies du moment aidant à se concentrer sur le clavier, je me suis remis aux évolutions des cartes
- Les cartes Suisses sont revenues grâce à la patience de Christian Kühni de SwissTopo qui m'a si bien conseillé
- Les cartes IGN ne sont plus écrasées grâce aux bons conseils de Florent Coste de vttrack.fr
- Les massifs sont maintenant colorés sous Safari grâce à la vigilance de SwissTrecker qui me l'a signalé
- Toutes les cartes sont disponibles sans recharger la page grâce à un bout de code de Florent Coste pompé sur vttrack.fr
- Toutes les cartes ont maintenant un logo, référence du fournisseur et conditions d'utilisation, grâce à la suggestion de Sylvain
- L'ensemble a gagné en fluidité et rapidité grâce aux évolutions de Openlayers version 2.11 (nombreux auteurs)
Pour Google, je suis passé sur V3: Il n'y a plus de bannières intempestives. Si ça se reproduit, on repassera en V2, mais comme elle doit disparaître à terme, je préfère refaire un essai.

Comme d'habitude, je vais solliciter vos dons de testeurs. J'ai fait de nombreux tests avec IE6, IE7, IE8, FF, Opéra sous XP, Safari et Chrome, mais il ne doit pas manquer de problèmes qui m'aient échappé.
Reste IE9 & 10 sur W7 et le tout sur Linux et Mac (je n'en ai pas)
Note: un bug reste sur Opera qui ne gère pas le survol ni le click sur les icônes. Je continue à investiguer, mais ça s'annonce compliqué (problème intrinsèque à OL2.11 et Opera). Comme je n'ai testé Opera que sous XP et que le pb semble lié à l'interpréteur java, il est possible qu'il n'y ait pas de problèmes sur W7. A confirmer.

Avatar du membre
sly
Messages : 1945
Enregistré le : dim. 29 févr., 2004 6:59 pm
Localisation : Chambéry - Savoie
Contact :

Message par sly » lun. 23 avr., 2012 12:51 am

Dominique a écrit : - Les cartes Suisses sont revenues grâce à la patience de Christian Kühni de SwissTopo qui m'a si bien conseillé
- Les cartes IGN ne sont plus écrasées grâce aux bons conseils de Florent Coste de vttrack.fr
- Les massifs sont maintenant colorés sous Safari grâce à la vigilance de SwissTrecker qui me l'a signalé
- Toutes les cartes sont disponibles sans recharger la page grâce à un bout de code de Florent Coste pompé sur vttrack.fr
- Toutes les cartes ont maintenant un logo, référence du fournisseur et conditions d'utilisation, grâce à la suggestion de Sylvain
- L'ensemble a gagné en fluidité et rapidité grâce aux évolutions de Openlayers version 2.11 (nombreux auteurs)
Pour Google, je suis passé sur V3: Il n'y a plus de bannières intempestives. Si ça se reproduit, on repassera en V2, mais comme elle doit disparaître à terme, je préfère refaire un essai.
Trop super bien !
Génial que du bon, super boulot !
et le tout sur Linux et Mac (je n'en ai pas)
Linux et FF 3.6 : top que ça marche
Linux + Opera : idem (sauf bug du survol+clic)

Et en effet, je crois bien que ça va plus vite qu'avant (très appréciable avec ma brouette de 8 ans que j'ai pas envie de changer)

Sinon :

le "+" en haut droite fait son retour, mais il n'est vraiment pas intuitif pour ceux qui ne connaissent pas, le texte "cartes" comme tu avais fais pendant un temps était plus mieux bien

Et des détails pas vraiment gênant :

Le layer en cours se place en première position, c'est à mon avis pas très ergonomique de faire qu'un menu se ballade

Quand on navigue à partir de la page d'accueil vers un massif, le permalink ne prends pas le dessus sur un zoom "adapté" au massif initialement choisi (je crois que c'était déjà comme ça)

Swisstrekker
Messages : 181
Enregistré le : mar. 13 avr., 2010 9:41 pm
Localisation : Alpes vaudoises

Message par Swisstrekker » lun. 23 avr., 2012 3:35 pm

Dominique a écrit :Bonjour

avec un peu de retard, les pluies du moment aidant à se concentrer sur le clavier, je me suis remis aux évolutions des cartes
- Les cartes Suisses sont revenues grâce à la patience de Christian Kühni de SwissTopo qui m'a si bien conseillé
- Les cartes IGN ne sont plus écrasées grâce aux bons conseils de Florent Coste de vttrack.fr
- Les massifs sont maintenant colorés sous Safari grâce à la vigilance de SwissTrecker qui me l'a signalé
- Toutes les cartes sont disponibles sans recharger la page grâce à un bout de code de Florent Coste pompé sur vttrack.fr
- Toutes les cartes ont maintenant un logo, référence du fournisseur et conditions d'utilisation, grâce à la suggestion de Sylvain
- L'ensemble a gagné en fluidité et rapidité grâce aux évolutions de Openlayers version 2.11 (nombreux auteurs)
Pour Google, je suis passé sur V3: Il n'y a plus de bannières intempestives. Si ça se reproduit, on repassera en V2, mais comme elle doit disparaître à terme, je préfère refaire un essai.

Comme d'habitude, je vais solliciter vos dons de testeurs. J'ai fait de nombreux tests avec IE6, IE7, IE8, FF, Opéra sous XP, Safari et Chrome, mais il ne doit pas manquer de problèmes qui m'aient échappé.
Reste IE9 & 10 sur W7 et le tout sur Linux et Mac (je n'en ai pas)
Note: un bug reste sur Opera qui ne gère pas le survol ni le click sur les icônes. Je continue à investiguer, mais ça s'annonce compliqué (problème intrinsèque à OL2.11 et Opera). Comme je n'ai testé Opera que sous XP et que le pb semble lié à l'interpréteur java, il est possible qu'il n'y ait pas de problèmes sur W7. A confirmer.
Le résultat est tellement impressionnant que je ne t'en veux même pas de massacrer mon pseudo, lol. Je te confirme que cela fonctionne impec sur Mac, bravo, très beau travail !

Avatar du membre
Dominique
Messages : 1150
Enregistré le : sam. 08 avr., 2006 9:58 pm
Localisation : Chaville 92
Contact :

Message par Dominique » lun. 23 avr., 2012 7:40 pm

sly a écrit :Linux + Opera : idem (sauf bug du survol+clic)
Ouaimf. J'ai testé sur Opera + W7 aujourd'hui : même bug
Il y a vraiment un pb avec les icônes affichées par GML/SLD sous Opera.
Il est vrai que peu de sites le font à ma connaissance (sauf vttrack, mais il a pompé mon code, donc il a aussi le bug puisqu'il est passé en OL2.11)
J'avais confondu au départ Opera et Safari, croyant qu'Opera était le navigateur d'Apple, donc je pensais qu'on avait peut être un pb dépendant du système d'exploitation mais non, Apple: c'est Safari. Et puis un bug sur un soft Apple...
Il faut vraiment que je trouve ce bug, parce que WRI est inutilisable sous Opera. Mais bon, pas facile, ça fait un bon moment que je le piste.
sly a écrit :le "+" en haut droite fait son retour, mais il n'est vraiment pas intuitif pour ceux qui ne connaissent pas, le texte "cartes" comme tu avais fais pendant un temps était plus mieux bien
celle là, je l'attendais. Je sais qu'on en avait abondamment discuté, mais je ne suis pas tout à fait d'accord. Le + est utilisé sur tous les sites OL (en général, il est bleu). De plus, le pavé carte qui baille sur une bonne partie de la vignette... bof.
Comme c'est une question de goûts et de couleurs et que ce n'est pas difficile, j'ai remis la version verticale, moins intrusive.
Tout avis externe est le bienvenu
sly a écrit :Le layer en cours se place en première position, c'est à mon avis pas très ergonomique de faire qu'un menu se ballade
Pour optimiser la vitesse d'affichage, je commence par la couche active.
tel que c'est fait aujourd'hui, j'inclue les couches quand elles sont initialisées, de sorte que la première initialisée se retrouve en haut
Il faut expliquer qu'une bonne partie du temps que j'ai mis à sortir ma nouvelle version a été passé à gérer les nouvelles interfaces des services qu commencent d'abord par un dialogue avec attente avant d'initialiser la couche
- SwissTopo d'abord, qui a inclus dans son interface un getCapabilities qui interroge le serveur pour connaître les paramètres des couches
- IGN à suivi avec sa demande de jeton
- Sans compter mon interface GML/SLD qui commence à aller chercher la feuille de style (SLD) avent de créer la couche elle-même (GML)
Quand on n'a qu'une couche qui fait ça dans le script inclus au début, on ne s'aperçoit de rien, mais quand on veut faire du multi source, on finit par attendre 20 secondes que tous les dialogues aient lieu avant d'afficher quoi que ce soit.
D'où l'optimisation de gérer moi-même en temps masqué ces interrogations de serveurs, mais ce n'est pas vraiment un concept intégré par les classes OL.
Une autre stratégie serait de créer toutes les couches au début inactives et en grisé et de ne les activer qu'au moment où elles sont chargées. J'étudie cette possibilité, mais c'est un gros changement d'architecture, donc ce sera pour une prochaine livraison.
sly a écrit :Quand on navigue à partir de la page d'accueil vers un massif, le permalink ne prends pas le dessus sur un zoom "adapté" au massif initialement choisi (je crois que c'était déjà comme ça)
Bien sur que si, j'adapte le zoom ! Essaye de cliquer sur le massif central puis sur les Grandes Rousses pour voir. C'est juste que si on zoom plus, le massif dépasse
Le bon positionnement de la carte n'a d'ailleurs rien à voir avec le permalink, il est calculé par PHP à partir des données SQL
Ou alors, je n'ai pas compris ta remarque

Avatar du membre
Dominique
Messages : 1150
Enregistré le : sam. 08 avr., 2006 9:58 pm
Localisation : Chaville 92
Contact :

Message par Dominique » mer. 02 mai, 2012 1:07 pm

Dernière minute. Je reçois le récapitulatif de la consommation des pixels SwissTopo
Entre le 22 et le 31 avril, nous avons consommé 10% de notre quota annuel
Ce qui veut dire que nous ne pouvons pas nous permettre de laisser la couche SwissTopo de la grande carte active si nous voulons garder suffisamment de quotas pour afficher les mini-cartes des pages de points toute l'année durant
Je vais essayer de trouver une autre source de cartes pour cette région.

-----------------------------------------------------------------------------------------------
Bonjour Monsieur Cavailhez

Vous avez utilisé 2'833'973'248 pixels de votre crédit de 25'000 Mpx pour la site web refuges.info.
Votre solde de 22'166'026'752 pixels est valable jusque le 01.09.2012.
Date d'évaluation: 01.05.2012

Meilleures salutations

Christian Kühni
Geodatenabgabe und analoge Archive

Eidgenössisches Departement für Verteidigung,
Bevölkerungsschutz und Sport VBS
armasuisse
Bundesamt für Landestopografie swisstopo

Swisstrekker
Messages : 181
Enregistré le : mar. 13 avr., 2010 9:41 pm
Localisation : Alpes vaudoises

Message par Swisstrekker » mer. 02 mai, 2012 1:54 pm

Je retrouve dans cette réponse les perles du français "fédéral" de mes chers compatriotes suisse alémaniques... Cela dit, la solution de n'afficher les cartes Swisstopo qu'à la demande me semble effectivement être la meilleure solution.

Avatar du membre
Dominique
Messages : 1150
Enregistré le : sam. 08 avr., 2006 9:58 pm
Localisation : Chaville 92
Contact :

Message par Dominique » sam. 11 août, 2012 8:49 pm

Suite aux rapports de juillet de consommation de pixels SwissTopo (2.37 Mpixels), je constate que l'affichage de la carte google par défaut sur les vignettes de fiches de refuges suisses a permis de revenir à un débit compatible avec le contrat gratuit (25 Mpixels / an)
En conséquence, j'ai le plaisir de lever la restriction d'affichage de la grande carte
http://www.refuges.info/nav.php?baseLay ... le=1000000

Swisstrekker
Messages : 181
Enregistré le : mar. 13 avr., 2010 9:41 pm
Localisation : Alpes vaudoises

Message par Swisstrekker » sam. 11 août, 2012 9:11 pm

Super ! Et encore merci pour tous les efforts entrepris !

Avatar du membre
Dominique
Messages : 1150
Enregistré le : sam. 08 avr., 2006 9:58 pm
Localisation : Chaville 92
Contact :

Message par Dominique » sam. 03 nov., 2012 8:40 pm

Bonjour Monsieur

Vous avez utilisé 5’525’012’480 pixels de votre crédit de 25'000 Mpx pour le site web refuges.info.

Votre solde de 19’474’987’520 pixels est valable jusqu'au 01.09.2013.

Date d'évaluation: 02.11.2012

Meilleures salutations


Aujourd’hui, comme tous les débuts de mois, je reçois le relevé de consommation de SuissTopo
Rien de bien catastrophique mais, à ce rythme là, on serait dans le noir les 3 derniers mois
Je retire donc temporairement la carte SwissTopo de la grande carte (elle reste disponible sur les vignettes des points et en édition)

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité