[Résolu] recherche de lieu par nom / espaces en trop

Problème/bug rencontré sur le site, évolution/amélioration à proposer
Bryce
Messages : 19
Enregistré le : lun. 06 oct., 2008 11:12 pm
Localisation : Grenoble

[Résolu] recherche de lieu par nom / espaces en trop

Message par Bryce » mer. 16 janv., 2013 11:03 am

salut,

juste un point de détail: j'ai remarqué que quand il y a un caractère espace à la fin du nom de refuge dans le champ de recherche, il n'est pas trouvé !
(ça arrive souvent quand on fait un copier/coller d'un nom en provenance d'une autre page qu'un espace soit collé à la fin...) => il faudrait supprimer tous les espaces en fin de chaîne. Sans doute d'autres champs de saisie sont concernés.

a+

Avatar du membre
sly
Messages : 1945
Enregistré le : dim. 29 févr., 2004 6:59 pm
Localisation : Chambéry - Savoie
Contact :

Message par sly » mer. 16 janv., 2013 2:42 pm

Salut,

Je confirme le problème, je pensais que c'état géré, mais on dirait que non.
Je viens de corriger le problème pour tous les futurs nom qui seront rentrés. Et j'ai corrigé les fiches existantes qui présentaient le problème.

Merci de cette trouvaille !

Bryce
Messages : 19
Enregistré le : lun. 06 oct., 2008 11:12 pm
Localisation : Grenoble

Message par Bryce » sam. 19 janv., 2013 11:47 am

sly a écrit :Salut,

Je confirme le problème, je pensais que c'état géré, mais on dirait que non.
Je viens de corriger le problème pour tous les futurs nom qui seront rentrés. Et j'ai corrigé les fiches existantes qui présentaient le problème.

Merci de cette trouvaille !
Ca n'a pas l'air de fonctionner !? :(

Avatar du membre
sly
Messages : 1945
Enregistré le : dim. 29 févr., 2004 6:59 pm
Localisation : Chambéry - Savoie
Contact :

Message par sly » sam. 19 janv., 2013 12:31 pm

ha ?

tu pourrais indiquer un exemple de cabane avec le problème ? et/ou un exemple de recherche qui créé le problème ?

Bryce
Messages : 19
Enregistré le : lun. 06 oct., 2008 11:12 pm
Localisation : Grenoble

Message par Bryce » sam. 19 janv., 2013 12:41 pm

sly a écrit :ha ?

tu pourrais indiquer un exemple de cabane avec le problème ? et/ou un exemple de recherche qui créé le problème ?
par exemple: Recherche, dans Options de recherche / Nom je saisis "Tubanet " (avec un espace à la fin) => 0 point trouvé
(pour info j'utilise Firefox 18.0)

Avatar du membre
Claude Mauguier
Messages : 553
Enregistré le : ven. 08 avr., 2011 3:31 pm
Localisation : Isére

Message par Claude Mauguier » sam. 19 janv., 2013 1:00 pm

je viens de rechercher tubanet, avec la même procédure, mais sans espace à la fin il est vrai (sous google Chrome) : pas de problème....

Avatar du membre
sly
Messages : 1945
Enregistré le : dim. 29 févr., 2004 6:59 pm
Localisation : Chambéry - Savoie
Contact :

Message par sly » sam. 19 janv., 2013 1:46 pm

Ok, pigé, le problème était donc double :

- Sur la saisie des fiches qui pouvaient avoir des espaces en trop (que j'avais corrigé après mon premier message)
- Sur la recherche qui recherchait "vraiment ce qu'on lui demandait" espace compris s'il y était alors qu'en effet, on pourrait s'attendre à ce que l'espace de fin de soit pas un vrai critère de recherche.

Voilà qui est donc également corrigé

Bryce
Messages : 19
Enregistré le : lun. 06 oct., 2008 11:12 pm
Localisation : Grenoble

Message par Bryce » sam. 19 janv., 2013 3:32 pm

sly a écrit :Ok, pigé, le problème était donc double :

- Sur la saisie des fiches qui pouvaient avoir des espaces en trop (que j'avais corrigé après mon premier message)
- Sur la recherche qui recherchait "vraiment ce qu'on lui demandait" espace compris s'il y était alors qu'en effet, on pourrait s'attendre à ce que l'espace de fin de soit pas un vrai critère de recherche.

Voilà qui est donc également corrigé
Cool, cette fois ça marche ! Mon premier message n'était peut-être pas assez clair...
Merci :)

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités